Transmitter problems

[Copy the Link] Views:572 | Replies:17
Post on March 14,2017 12:20#1
I bought a transmitter called FS-TH9X in Oktober 2016. It have worked good the few times I have tested it. Now, when I am ready to install it something have got wrong. When I put it on itsays beep, beep, beep all the time and the display say "Switch Error!" and every function is blocked. What can I do to make it working again?  
Report a Post Quote Reply
Post on March 14,2017 21:08#2

Ensure all switches are set in the fully back position, switches on the front of the unit must be up and those on top must be toward the rear.  Having just one switch in the wrong direction can cause this problem.  Also make sure your throttle is set to closed, (at the bottom, zero throttle)   Let me know if this solves your problem. 

Switch off, set all switches as I've said and then switch on, your problem should be solved.   Regards  Stu

Report a Post Quote Reply
Post on March 15,2017 01:15#3
Hi , would you please contact our customer service
Please send us your order number and a video or some pictures to show your problem.

We will help you.

More Discussion / Chat More in RC Zone

Report a Post Quote Reply
Post on March 15,2017 11:37#4
Thanks for Your tips Stu. But sad enough it did not work
Report a Post Quote Reply
Post on March 15,2017 15:24#5

Sorry Janne, it is a common mistake people make and I've been caught myself with it, as have many others. I was sure that was you problem. So much so I'm wondering if perhaps a wire may have a bad connection with one of the switches. I had to replace a switch on one of my transmitters and being in a hurry to get my plane back in the air I failed to make a good enough solder joint one one pin of the switch. I got exactly the same problem. "Switch Error" I blame the rather poor LiPo powered soldering iron and the fact I was sitting in the middle of a local sports field doing the repair 

That's all I can offer Janne, sorry, I've been very lucky with all my transmitters and the switch has been the only problem I've had in many years. Those radios are very reliable, in fact I like them so much I have 4 of them. I use two wired as buddy radios.

I assume you have the radio switched to PPM mode.  PCM won't work with the standard module. Make sure your battery is fully charged if you're using LiPo power. If you're using AA cells then make sure they are all OK.  Having low power can also show the switch error if the battery power is low, it tends to lock in the last error when the power gets low.  If you're running AA cells I definitely recommend you change to using a kow C rated LiPo or LiFe battery There are mods for using 2 cell lipos, but I've been using 3 cells lipos with no problems, just don't forget to switch the radio off when it's not in use, it will kill the battery if you don't.

If you've had you radio apart for any reason it's possible that one of the motherboard connectors has been pulled loose. Check to make sure all plugs are pushed home. I keep coming back to a switch problem, I'm sure that's what it is. The radio is partially hand soldered and the switches have been know to have wires badly soldered and some cases not soldered at all. It may pay you to open the radio up and check that there are no loose wires or loose plugs. When you take the back off, you'll find the back is connected with two plugs (from memory) to make things easier to get at you can pull the two plugs out of the motherboard and then you'll have full access. Don't panic there's one big plug and one small so you can't get them mixed up. You'll find the wires to the switches are twisted together, but by gently pulling on them you may find a loose wire, if you do then it will have to be soldered back on, sometimes it's easier to pull the whole switch out of the case to get at the pin you need.  If you can't solder it yourself see if you can find someone who can, a friend is usually cheaper than your local hobby shop.

A shame you don't live close by, I'd happily check it out for you.  Just checking, make sure you have the switches set properly PLUS have the throttle at the bottom. By the way, I don't suppose you've reset the endpoints for the throttle. I just had a flash, if you've set the endpoint for low throttle too high, it may not be registering and causing the radio to think you haven't set the throttle to zero. Watch the display and see what the reading is when you close the throttle. If it's set too high that could cause your problem as well.  Sorry I'm being long winded, I just like to make sure you understand what I'm on about  Let me know how you go.   Stu

Report a Post Quote Reply
Post on March 15,2017 17:17#6

Thanks again STU! One of the switches got loose once and i put it back again. Maybe some cable got loose under that process. I'll check tomorrow. I am living on an Island in the Stockholm archipelago, so I have a couple of hours before I am at some hobbyshop. I have sent a message to "Banggood" about this too. Maybe they will answer, but for the moment I think that the switch is the problem. Where do You live? I have LIPO batteries to the reciever and motor, but in the transmitter I have 8 chargeable AA batteries. My voltmeter say they give 12,8 volt right now. I have also got a charger that is so advanced I can't use it. I don't understand how to do. I have played with modeltrains in my life and have a digtalised layout here, so I have made a lot of soldering, no problems there.  And I know a little about electricity too. But I must tell you that I am VERY pleased to have got You as a contact. I hope it will continue. I'll tell You tomorrow my progress if I do?


Report a Post Quote Reply
Post on March 16,2017 09:57#7
Report a Post Quote Reply
Post on March 16,2017 15:41#8

Okej, now I have opened the transmitter and checked out the solders. they seem alright. I used tweezers to draw in the wires and test the solders. I screw it together again and WOW it did not say Switch error.... it said NOTHING! Totally dead. Open it again and pushed all contacts together HARD an d now it started "Switch Error" of course. Open it for the third time, I had found out that I didn't check the switches in the front. Nothing wrong ther. Closed it and started it. "Beep,beep,beep" and "switch error" again. I'm back to step 1. And I have NOT adjusted anything on the transmitter. Maybe I should throw it hard in the wall and buy a new one. That is how I feel for the moment. This weekend I have to go for a conference and I must prepare me for that. So nothing more will be done before Monday, but I will READ your answer with a big interest!


Report a Post Quote Reply
Post on March 17,2017 00:51#9

Hi Janne, sorry I can not help with the problem, but have you contacted our customer service

If yes, is there anyone who replied you?

More Discussion / Chat More in RC Zone

Report a Post Quote Reply
Post on March 17,2017 02:13#10
Yes, I have contacted and NO, I have not got any reply.
Report a Post Quote Reply
Message:(5 words at least)
Question Topic: