Anyone got success in flashing new firmware?

[Copy the Link] Views:8871 | Replies:39
Post on November 29,2015 06:53#1

Apart from the buzzer issue, which is not critical if you know about, I cant seem to get this thing flashed.

I tried every combination on Cleanflight GUI, with and without shorted bootloader pins. A buddy of mine managed to get latest betaflight_SPRACINGF3.hex on his board after many attempts, but it seems my board doesnt want it. It always fails to communicate to the bootloader.

Any experience or information regarding this? Would love to flash betaflight or at least be able to reflash CF.

Report a Post Quote Reply
Post on November 29,2015 17:18#2
no not yet: I cannot flash the device. I just read that this is a clone: maybe there is a protection programmed by the copyright holder.
Report a Post Quote Reply
Post on November 30,2015 12:31#3
It worked using Manual baud rate at 256000!
Report a Post Quote Reply
Post on December 01,2015 07:08#4

mine stops at 75% ...


did a calibration and retried ... successful!

Report a Post Quote Reply
Post on December 05,2015 15:57#5
disconnect reconnect and be sure "manual baud rate" is selected and it should flash just fine. I'm running betaflight without a problem.
Report a Post Quote Reply
Post on December 10,2015 01:20#6

What you have to do is download a driver. 

 https://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx  

 just download and install the driver and bang your in.. Nothing worked before i did this. 

 When i bought the sp f3 racing board i thought it was Dominic Cliftons.

 He doesn't get paid for his effort by banggood.. so!

What we all could do is to donate to cleanflight so Dominic gets paid.

I donate every now and then.. With out him we wouldn't have cleanflight.

Report a Post Quote Reply
Post on December 11,2015 19:51#7
Having the same problem. Flashing The board dont work. manual baud rate didn't helped :(
Report a Post Quote Reply
Post on December 15,2015 14:23#8

I attempted to update the firmware and made the mistake of loading the wrong version. Now i am having problems connecting, I have tried shorting the boot pins and changing the baud rate without any success. The first time I tried shorting the boot pins it appeared to connect and update, disconnected and reconnected and nothing.

Any helpful suggestions would be appreciated.

Report a Post Quote Reply
Post on December 18,2015 09:13#9
I flashed mine to betaflight 2.1.5 it timed out at first but I reloaded the CleanFlight fw update then flashed to betaflight and it worked fine . i set manual baud rate to 256000 per the manual. make sure to have "local" file loaded before u press flash
Report a Post Quote Reply
Post on December 22,2015 03:11#10

La mia no conectaba de ninguna forma, hasta que me cargue el bot de mi naze y al probar a instalarlo no me dejaba. Tras buscar info pude hacerlo y al pasarle a mi sp3 probe el sistema de la naze y por fin pude.

Habia probado el manual Baudrate, puentear los pads y quitarlo como pone el manual, etc etc.

Puentear los pads y DEJARLOS PUENTEADOS. enchufar el USB Flashear, desconectar usb, desconectar el pad.

Mine does not connect in any way, until I upload my naze bot and try to not let me install it. After searching info I could do and happen to my sp3 system and try same  the Naze and finally I could.
Had tasted the baud manual bypass and remove the pads and put the manual, etc etc.

I found this and work ok:

1) Get a friend, spouse, or offspring to help. You'll need an extra set of hands unless you want to solder the bootloader pins then remove the solder.
2) Check the box for "No Reboot Sequence" in the Firmware Flasher section.
3) Short the the bootlaoder pins and keep them shorted. I just held a pair of tweezers to both pads while my son did the following steps.
4) Connect the USB to the computer (you should have already had the other end connected to the Naze32).
5) Load the firmware and flash the file.
6) When it says successful, then you can remove the short on the bootloader pads.
7) Let out the breath you've been holding and relax. All is well.
Report a Post Quote Reply
Subject:
Message:(5 words at least)
Subject:
Question Topic: